Overview
If you are using Cube-IQ installed under a Concurrent License, it means that your copy of Cube-IQ is configured to validate its licensure status every time the software starts up. This means that every time you start the software, it must connect to a license checker service running somewhere on your company’s network.
When Cube-IQ can’t connect to this service, or if the service can’t verify your company’s license, it can prevent you from operating the software normally. This article will help you troubleshoot your Cube-IQ Concurrent installation.
Symptoms
If you’re having trouble related to your Cube-IQ’s Concurrent installation, you will likely be met with a dialog box when you try to start the software, which will contain a message like one of those shown below.
Possible Causes
NetKey: Cannot connect to the NetKey License Server
- This message means that your Cube-IQ software is not able to connect to the NetKey license checker service that should be running on your company’s network.
- This could be because:
- The service is not running.
- Cube-IQ is trying to connect to the service at an incorrect location.
NetKey: License is required
- This message indicates that Cube-IQ is connecting to the license server, but the service is not providing the software with a valid license.
- This can be because the license:
- Has expired.
- Service has been moved or reinstalled.
NetKey: Number of concurrent network users has reached the limit
- Your concurrent license for Cube-IQ is set to accommodate a specific number of users at a time.
- The license checker keeps track of how many users are using the software at one time.
- If it reaches the limit, it will not validate any more users until one or more of the other users closes the software.
Troubleshooting Steps
Error: "NetKey cannot connect to the license server"
If you get an error message that says “NetKey cannot connect to the license server.” follow these steps to troubleshoot the problem:
- Find the server where the License Checker is installed.
- It should be in a folder called NetKey40EK.
- Open Services and look for the NetKey40EK service.
- Check the service’s Status.
- If it is not “Running,” restart the service.
- If it is not “Running,” restart the service.
- Try to restart Cube-IQ on the workstation where you were having the problem.
- If it starts, you are finished, and you may ignore the rest of the steps.
- Otherwise, continue to step 6.
- Make a note of the IP address of this server on your network.
- You can usually get this by opening a Windows command prompt and entering the command `ipconfig`.
- Open the NKLS.ini file in the NetKey40EK installation folder.
- Make a note of the Port setting in the NKLS.ini file.
- Go to a Cube-IQ workstation on your network where you are not able to open Cube-IQ. All subsequent steps are to be performed on the Cube-IQ workstation, not on the server running the license service.
- In the Cube-IQ installation folder, find the file called NetKey.ini.
- In the file NetKey.ini, make sure the ServerAddress matches the IP address you made a note of in Step 5.
- In the file NetKey.ini, make sure the ServerPort matches the port number you made a note of in Step 7.
- If you still cannot connect to the license key service, check that your connection to the server is not blocked by a firewall.
Error: "License Key Required"
If you get the error message that says “License Key Required,” contact MagicLogic Support for a new license key.
Error: “Number of concurrent network users has reached the limit”
If you get the error message that says “Number of concurrent network users has reached the limit”:
- Find out how many users are currently connecting to the Cube-IQ license server.
- Ask one of the users to close Cube-IQ.
- Try to open the software on your workstation.
- Repeat Step 2 until you are able to open and use Cube-IQ at your workstation.
Further Assistance
If any further assistance is needed, please contact our Support team.
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