Overview
This article is about troubleshooting your BlackBox's inability to produce images of your load plan.
Symptoms
BlackBox is accepting loads and optimizing them, but the pictures of your load plan are not appearing in your designated Images folder.
Possible Causes
- The path to the Images folder in your initialization file is incorrect.
- The program has lost its connection to a module that is necessary to produce graphics. This can happen when:
- The software is replaced, updated, or moved.
- Your operating system is updated.
- Malware or another issue has corrupted your .dll registrations.
Troubleshooting Steps
- In your BlackBox installation folder, locate the file named BlackBoxTCP5.ini.
- Note: If you use Version 4 of BlackBox, this file will be named BlackBoxTCP4.ini.
- Locate the line that begins with
ImageFolder=. - Make sure the path matches the absolute path to the folder where you want BlackBox to save your images.
- Example:
ImageFolder=C:\MagicLogic\BB5\Images
- Example:
- At this time, you may restart BlackBox and submit another load. If the images are still not appearing, continue to the next step.
- Open a Command Prompt on your PC as administrator.
- Use the change directory cd command to change your working directory to the BlackBox installation folder.
- Example:
cd C:\MagicLogic\BB5
- Example:
- Run the command
regsvr32 CGElibrary.dll. - A dialog box should appear on your screen indicating that the file has been successfully registered with Windows.
- Click OK.
- Restart BlackBox and submit another load.
- The load plan images should appear in your image folder after optimization.
Assistance
If any further assistance is needed, please contact our Support team.